increase dvbapp PR.
[vuplus_openembedded] / recipes / ixp4xx / ixp4xx-npe_2.1.bb
1 DESCRIPTION = "NPE firmware for the IXP4xx line of devices"
2 LICENSE = "Intel Public Licence"
3 PR = "r6"
4 DEPENDS = "ixp4xx-npe-native"
5
6 SRC_URI = "http://www.intel.com/Please-Read-The-BB-File/IPL_ixp400NpeLibrary-2_1.zip"
7 do_unpack[depends] += "unzip-native:do_populate_staging"
8 S = "${WORKDIR}/ixp400_xscale_sw/src/npeDl"
9
10 COMPATIBLE_MACHINE = "(nslu2|ixp4xx)"
11
12 FILES_${PN} = "${base_libdir}/firmware/NPE-B"
13
14 do_compile() {
15         ${STAGING_BINDIR_NATIVE}/IxNpeMicrocode-${PV} -be
16 }
17
18 do_install() {
19         install -d ${D}/${base_libdir}/firmware/
20         rm ${S}/NPE-B
21         mv ${S}/NPE-B.* ${S}/NPE-B
22         install ${S}/NPE-B ${D}/${base_libdir}/firmware/
23 }
24