Merge remote-tracking branch 'dm/opendreambox-1.6' into test_0701
[vuplus_openembedded] / recipes / ivman / ivman_0.6.14.bb
1 DESCRIPTION = "Daemon to mount/unmount devices, based on info from HAL"
2 HOMEPAGE = "http://ivman.sf.net"
3 LICENSE = "GPLv2"
4 PR = "r1"
5
6 DEPENDS = "hal libxml2"
7 RDEPENDS = "hal pmount-hal"
8
9 SRC_URI = "${SOURCEFORGE_MIRROR}/ivman/${P}.tar.bz2 \
10            file://ivman-0.6-hotpluggable.patch;patch=1 \
11            file://ivman-launch.patch;patch=1 "
12
13 inherit autotools
14
15 # Add user ivman into group plugdev
16 pkg_postinst_${PN} () {
17         # can't do this offline
18         if [ "x$D" != "x" ]; then
19                 exit 1
20         fi
21
22         grep "^ivman:" /etc/passwd > /dev/null || \
23              adduser --disabled-password --system --home /dev/null \
24                      --no-create-home --ingroup plugdev -s /bin/false \
25                      -g "IVMAN" ivman
26         /etc/init.d/populate-volatile.sh update
27 }
28
29 pkg_postrm_${PN} () {
30         deluser ivman || true
31 }