increase dvbapp PR.
[vuplus_openembedded] / recipes / irssi / irssi_0.8.13.bb
1 DESCRIPTION = "Irssi is a modular IRC client with Perl scripting."
2 HOMEPAGE = "http://irssi.org/"
3 SECTION = "console/network"
4 LICENSE = "GPL"
5 DEPENDS += "ncurses glib-2.0"
6
7 PACKAGES += "${PN}-common"
8 FILES_${PN} = "${bindir}/irssi"
9 FILES_${PN}-common = "${datadir}/irssi ${sysconfdir}"
10 RDEPENDS_${PN} += "${PN}-common"
11
12 inherit autotools
13
14 SRC_URI = "http://www.irssi.org/files/${P}.tar.bz2 \
15 "
16
17 EXTRA_OECONF = "--enable-ipv6 \
18                 --disable-ssl \
19                 --disable-glibtest \
20                 --without-socks \
21                 --with-textui \
22                 --without-bot \
23                 --without-proxy \
24                 --with-perl=no \
25                 --with-ncurses=${STAGING_LIBDIR}/.."
26
27 do_configure () {
28         # create help files
29         echo "Creating help files..."
30         perl syntax.pl
31
32         files=`echo docs/help/in/*.in|sed -e 's,docs/help/in/Makefile.in ,,' -e 's,docs/help/in/,!,g' -e 's/\.in /.in ?/g'`
33         cat docs/help/in/Makefile.am.gen|sed "s/@HELPFILES@/$files/g"|sed 's/?/\\?/g'|tr '!?' '\t\n' > docs/help/in/Makefile.am
34
35         files=`echo $files|sed 's/\.in//g'`
36         cat docs/help/Makefile.am.gen|sed "s/@HELPFILES@/$files/g"|sed 's/?/\\?/g'|tr '!?' '\t\n' > docs/help/Makefile.am
37
38         # .HTML -> .txt with lynx
39         # echo "Documentation: html -> txt..."
40         # lynx -dump -nolist docs/faq.html|perl -pe 's/^ *//; if ($_ eq "\n" && $state eq "Q") { $_ = ""; } elsif (/^([QA]):/) { $state = $1 } elsif ($_ ne "\n") { $_ = "   $_"; };' > docs/faq.txt
41         > docs/faq.txt
42
43         autotools_do_configure
44 }
45
46 do_stage () {
47         find . -name \*.h | for h in `cat`; do
48                 install -d ${STAGING_LIBDIR}/../irssi/`dirname $h`
49                 install -m 0644 $h ${STAGING_LIBDIR}/../irssi/$h
50         done
51         find . -name lib\*.a | for l in `cat`; do
52                 install -d ${STAGING_LIBDIR}/../irssi/`dirname $l`
53                 install -m 0644 $l ${STAGING_LIBDIR}/../irssi/$l
54         done
55         install -m 0644 irssi-config ${STAGING_LIBDIR}/../irssi/
56 }
57
58 do_install () {
59         autotools_do_install
60         rm -f ${D}${docdir}/irssi/faq.txt
61 }