increase dvbapp PR.
[vuplus_openembedded] / recipes / irda-utils / irda-utils_0.9.16.bb
1 DESCRIPTION = "Provides common files needed to use IrDA. \
2 IrDA allows communication over Infrared with other devices \
3 such as phones and laptops."
4 SECTION = "base"
5 LICENSE = "GPL"
6 PR = "r9"
7
8 SRC_URI = "${SOURCEFORGE_MIRROR}/irda/irda-utils-${PV}.tar.gz \
9            file://configure.patch;patch=1 \
10            file://m4.patch;patch=1 \
11            file://ldflags.patch;patch=1 \
12            file://sbindir.patch;patch=1 \
13            file://init"
14
15 export SYS_INCLUDES="-I${STAGING_INCDIR}"
16
17 inherit autotools
18
19 INITSCRIPT_NAME = "irattach"
20 INITSCRIPT_PARAMS = "defaults 20"
21
22 do_compile () {
23         oe_runmake -e -C irattach
24         oe_runmake -e -C irdaping
25 }
26
27 do_install () {
28         install -d ${D}${sbindir}
29         oe_runmake -C irattach ROOT="${D}" sbindir="${sbindir}" install
30         oe_runmake -C irdaping ROOT="${D}" sbindir="${sbindir}" install
31
32         install -d ${D}${sysconfdir}/init.d
33         install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/${INITSCRIPT_NAME}
34 }