increase dvbapp PR
[vuplus_openembedded] / recipes / iozone3 / iozone3_263.bb
1 DESCRIPTION = "Filesystem and Disk Benchmarking Tool"
2 HOMEPAGE = "http://www.iozone.org/"
3 AUTHOR = "Don Capps <don.capps2@verizon.net>, William D. Norcott <wnorcott@us.oracle.com>"
4 SECTION = "console/tests"
5 LICENSE = "${PN}"
6
7 PR = "r1"
8
9 SRC_URI = "http://www.iozone.org/src/current/iozone3_263.tar \
10            file://copyright.txt \
11            file://fileop-arm.patch;patch=1"
12
13 S = "${WORKDIR}/${PN}_${PV}/src/current/"
14
15 EXTRA_OEMAKE = "linux-arm CC='${CC}'"
16
17 TARGET_CC_ARCH += "${LDFLAGS}"
18
19 do_install() {
20        install -d ${D}${bindir} \
21                   ${D}${mandir}/man1 \
22                   ${D}${datadir}/doc/${PN}/examples
23
24        install -m 0755 ${S}/iozone ${D}${bindir}
25        install -m 0755 ${S}/fileop ${D}${bindir}
26        install -m 0644 ${WORKDIR}/${PN}_${PV}/docs/iozone.1 ${D}${mandir}/man1/
27        install -m 0644 ${WORKDIR}/copyright.txt ${D}${datadir}/doc/${PN}/
28
29        install -m 0644 ${S}/*.dem ${D}${datadir}/doc/${PN}/examples
30        install -m 0644 ${S}/client_list ${D}${datadir}/doc/${PN}/examples
31        install -m 0644 ${S}/Gnuplot.txt ${D}${datadir}/doc/${PN}/examples
32
33        install -m 0755 ${S}/Generate_Graphs ${D}${datadir}/doc/${PN}/examples
34        install -m 0755 ${S}/gengnuplot.sh ${D}${datadir}/doc/${PN}/examples
35        install -m 0755 ${S}/report.pl ${D}${datadir}/doc/${PN}/examples
36
37        install -m 0644 ${WORKDIR}/${PN}_${PV}/docs/Iozone_ps.gz ${D}${datadir}/doc/${PN}/
38        install -m 0644 ${WORKDIR}/${PN}_${PV}/docs/IOzone_msword_98.pdf ${D}${datadir}/doc/${PN}/
39        install -m 0644 ${WORKDIR}/${PN}_${PV}/docs/Run_rules.doc ${D}${datadir}/doc/${PN}/
40 }
41
42 FILES_${PN} += "${datadir}/doc/${PN}/copyright.txt"
43
44 # LICENSE:
45 #
46 #  Copyright 1991, 1992, 1994, 1998, 1999, 2002   William D. Norcott
47 #
48 #  License to freely use and distribute this software is hereby granted
49 #  by the author, subject to the condition that this copyright notice
50 #  remains intact.  The author retains the exclusive right to publish
51 #  derivative works based on this work, including, but not limited to
52 #  revised versions of this work.
53 #
54
55 #
56 # Below is author reply to question about distributing iozone3 in
57 # OpenEmbedded:
58 #
59 # ========================================================================
60 #
61 # Marcin,
62 #
63 #         Re-distribution is permitted as long as the copyright is
64 #     maintained and the source code is not changed. I do not
65 #     see a problem with your mods to enable fileop for Linux-arm,
66 #     as these mods have been returned to the Iozone folks,
67 #     and they have been accepted for inclusion in the next
68 #     release :-)
69 #
70 # Thank you for your contribution,
71 # Don Capps
72 #
73 # ----- Original Message -----
74 # From: "Marcin Juszkiewicz" <firma@hrw.one.pl>
75 # To: "Don Capps" <don.capps2@verizon.net>; "William D. Norcott"
76 # <wnorcott@us.oracle.com>
77 # Sent: Sunday, October 29, 2006 4:55 PM
78 # Subject: iozone3 263 patch for arm and License question
79 #
80 #
81 # > Morning
82 # >
83 # > I want to include iozone3 in OpenEmbedded [1] metadata to give it for
84 # > other developers. Currently OE is used to build few distributions for
85 # > misc platforms: ARM, SH3, SH4, x86, PowerPC and different types of
86 # > machines (PDA, settopbox, devboards, desktops, thin clients, routers).
87 # >
88 # > According to your distribution of derivations is forbidden. Packaging
89 # > iozone3 in OpenEmbedded will not involve any source code changes. But
90 # > when I was building it for ARM I discovered that fileop binary was not
91 # > built - so I created patch for it (attached). Not yet tested it on target
92 # > device.
93 # >
94 # > Thus, I seek your written permission via e-mail to distribute a package of
95 # > the unmodified source code and also a package of the pre-compiled binary.
96 # > Your copyright statement will be included in the package.
97 # >
98 # >
99 # > 1. http://www.openembedded.org/
100 # >
101 # > Regards
102 # > --
103 # > JID: hrw-jabber.org
104 # > OpenEmbedded developer/consultant