dvbapp : TranscodingSetup update
[vuplus_openembedded] / recipes / ion / ion3_0.0+ds20041104.bb
1 BROKEN = "1"
2 # is unfetchable now - upstream updated to 20050728
3
4 DEPENDS += "lua-native lua virtual/libx11 libxext"
5 DESCRIPTION = "Ion is a tiling tabbed window manager designed with keyboard \
6 users in mind."
7 HOMEPAGE = "http://modeemi.fi/~tuomov/ion/"
8 LICENSE = "LGPL"
9 PROVIDES += "ion"
10 SECTION = "x11/wm"
11 SNAPDATE = "${@(bb.data.getVar('PV', d, 1) or '')[-8:]}"
12
13 # Currently excluded from world builds due to requiring a full libX11
14 # rather than diet.
15 BROKEN = "1"
16
17 SRC_URI = "http://modeemi.fi/~tuomov/ion/dl/ion-3ds-${SNAPDATE}.tar.gz \
18            file://201_fix-paths.diff;patch=1 \
19            file://202_fix-menus.diff;patch=1 \
20            file://203_fix-kludges.diff;patch=1 \
21            file://204_fix-bindings.diff;patch=1 \
22            file://205_ion-lock.diff;patch=1 \
23            file://206_use-xterm.diff;patch=1 \
24            file://luaconfig.patch;patch=1 \
25            file://cross.patch;patch=1"
26 S = "${WORKDIR}/ion-3ds-${SNAPDATE}"
27
28 EXTRA_OECONF += "--disable-xinerama --disable-xfree86-textprop-bug-workaround \
29                  --disable-Xutf8 --disable-sun-fix-remap --enable-shared \
30                  --with-lua-prefix=${STAGING_BINDIR_NATIVE}/.. \
31                  --x-libraries=${STAGING_LIBDIR} \
32                  --x-includes=${STAGING_INCDIR}"
33
34 inherit autotools