Merge commit 'opendreambox/opendreambox-1.6' into vuplus-1.6
[vuplus_openembedded] / recipes / inputpipe / inputpipe_svn.bb
1 SECTION = "base"
2 PRIORITY = "optional"
3 DESCRIPTION = "Inputpipe is a network transparency layer for linux input devices"
4 LICENSE = "GPL"
5 #Remove the dash below when 0.5 changes in PV
6 PV = "0.5+svn-${SRCDATE}"
7 SRC_URI = "svn://svn.navi.cx/misc/trunk;module=inputpipe;proto=http"
8
9 S = "${WORKDIR}/inputpipe"
10
11 do_compile() {
12         oe_runmake CC="${CC}" CFLAGS="-I ${WORKDIR}/inputpipe/uinput ${CFLAGS}"
13 }
14
15 do_install() {
16         install -d ${D}${bindir}
17         install inputpipe-server ${D}${bindir}
18         install inputpipe-client ${D}${bindir}
19 }
20
21 PACKAGES = "${PN}-dbg inputpipe-server inputpipe-client ${PN}"
22
23 FILES_inputpipe-client = "${bindir}/inputpipe-client"
24 FILES_inputpipe-server = "${bindir}/inputpipe-server"