dvbapp : TranscodingSetup update
[vuplus_openembedded] / recipes / initrdscripts / devimage_0.1.bb
1 DESCRIPTION = "Set of files to initialize bare system suitable for kernel, etc. testing."
2 SRC_URI = "file://devimage.sh file://passwd file://dropbear_rsa_host_key"
3 PR = "r4"
4
5 do_install() {
6         install -d ${D}/etc/dropbear
7         install -d ${D}/sbin
8         install -m 0755 ${WORKDIR}/devimage.sh ${D}/init
9         install -m 0600 ${WORKDIR}/dropbear_rsa_host_key ${D}/etc/dropbear/
10         install -m 0644 ${WORKDIR}/passwd ${D}/etc/
11         ln -s /init ${D}/sbin/init
12 }
13
14 FILES_${PN} += " /init /etc/* /sbin/*"