enigma2 : change vfd font (skin_user.xml)
[vuplus_openembedded] / recipes / images / udumpty-image.bb
1 # Image that mimics the default desktop of a certain distro
2
3 SPLASH ?= ' ${@base_contains("MACHINE_FEATURES", "screen", "psplash-angstrom", "",d)}'
4 XSERVER ?= "xserver-xorg \
5            xf86-input-evdev \
6            xf86-input-mouse \
7            xf86-video-fbdev \
8            xf86-input-keyboard \
9 "
10
11
12 ANGSTROM_EXTRA_INSTALL ?= ""
13
14 export IMAGE_BASENAME = "Udumpty-image"
15
16 DEPENDS = "task-base"
17 IMAGE_INSTALL = "\
18     ${XSERVER} \
19     task-base-extended \
20     angstrom-x11-base-depends \
21     angstrom-gpe-task-base \
22     ${ANGSTROM_EXTRA_INSTALL} \
23     angstrom-zeroconf-audio \
24     angstrom-led-config \ 
25     gpe-scap \
26     psplash \
27     metacity \
28     xterm \ 
29     epiphany \
30     swfdec-mozilla \
31     hicolor-icon-theme gnome-icon-theme \
32     abiword \
33     gnumeric \
34     gimp \
35     powertop oprofile \
36     pidgin \
37     totem mplayer omapfbplay \
38     gnome-games \
39     rt73-firmware zd1211-firmware \
40         synergy \
41         x11vnc \
42         angstrom-gnome-icon-theme-enable \
43         gnome-panel \
44         gnome-control-center \
45         gnome-settings-daemon \
46         gnome-session \
47     ${SPLASH} \
48 "
49
50 IMAGE_PREPROCESS_COMMAND = "create_etc_timestamp"
51
52 #zap root password for release images
53 ROOTFS_POSTPROCESS_COMMAND += '${@base_conditional("DISTRO_TYPE", "release", "zap_root_password; ", "",d)}'
54
55 inherit image