increase dvbapp PR
[vuplus_openembedded] / recipes / images / nas-server-image.bb
1 # This image is intended to provide a configuration
2 # for a network attached storage server device.
3
4 # Key features are:
5
6 # 1) Must be able to mount attached storage devices like
7 # internal disks, external USB disks, etc.  Should support
8 # various filesystem choices, but ext2 at a minimum.
9 #
10 # 2) Must be able to boot from internal flash, or directly
11 # from a filesystem stored on the attached storage.
12 #
13 # 3) Must be able to share that storage across the network
14 # using various protocols like Samba, NFS, etc.
15 #
16 # 4) Bonus points for being able to support other central
17 # network services like a central gateway machine might.
18
19 # Although it is tested with the Angstrom distro, it is
20 # intended to be distro-agnostic.
21
22 DISTRO_SSH_DAEMON ?= "dropbear"
23 DISTRO_PACKAGE_MANAGER ?= "opkg-nogpg opkg-collateral"
24
25 DEPENDS = "\
26         task-boot \
27         ${@base_contains('MACHINE_FEATURES', 'apex', 'task-base-apex', '', d)} \
28         task-distro-base task-machine-base \
29         ${DISTRO_SSH_DAEMON} \
30         ${DISTRO_PACKAGE_MANAGER} \
31         ${@base_contains('MACHINE_FEATURES', 'ext2', 'task-base-ext2', '', d)} \
32         ${@base_contains('MACHINE_FEATURES', 'usbhost', 'task-base-usbhost', '', d)} \
33         task-nas-server-everything \
34         "
35
36 IMAGE_INSTALL_TASKS = "\
37         task-nas-server-everything \
38         "
39
40 IMAGE_INSTALL = "\
41         task-boot \
42         ${@base_contains('MACHINE_FEATURES', 'apex', 'task-base-apex', '', d)} \
43         ${DISTRO_SSH_DAEMON} \
44         ${DISTRO_PACKAGE_MANAGER} \
45         ${@base_contains('MACHINE_FEATURES', 'ext2', 'task-base-ext2', '', d)} \
46         ${@base_contains('MACHINE_FEATURES', 'usbhost', 'task-base-usbhost', '', d)} \
47         ${IMAGE_INSTALL_TASKS} \
48         "
49
50 export IMAGE_BASENAME = "nas-server-image"
51 IMAGE_LINGUAS = ""
52
53 inherit image