Merge branch 'master' of git://dev.doredevelopment.dk/oe-micro into org.openembedded.dev
[vuplus_openembedded] / recipes / images / micro-image.bb
1 # micro-image
2 #
3 # Image configuration for the OE Micro Linux Distribuion (micro, micro-uclibc)
4 #
5 # This image basically consists of: libc, busybox, udev, sysv init, and a few
6 # init scripts for running up the system.
7 #
8 # It is truely tiny and should build with most architectures/machines.
9 #
10 # The image is tested to build and run succesfully with the following machines:
11 #
12 #       * at91sam9263ek (jffs2 image size ~ 1 MB, uclibc)
13 #       * x86
14 #
15 # Maintainer: Martin Lund <mgl@doredevelopment.dk>
16 #
17
18 # Install basic files only
19 IMAGE_INSTALL = "base-files base-passwd"
20 IMAGE_LINGUAS = ""
21
22 # Use busybox as login manager
23 IMAGE_LOGIN_MANAGER = "busybox"
24
25 # Include minimum init and init scripts
26 IMAGE_DEV_MANAGER = "udev"
27 IMAGE_INIT_MANAGER = "sysvinit sysvinit-pidof"
28 IMAGE_INITSCRIPTS = ""
29
30 # Do not install target package management system
31 ONLINE_PACKAGE_MANAGEMENT = "none"
32
33 inherit image
34