Merge branch 'opendreambox-1.6' into vuplus-1.6
[vuplus_openembedded] / recipes / icommand / icommand-bluez_0.7.bb
1 DESCRIPTION = "iCommand bluez binding"
2 LICENSE = "LGPL"
3 SECTION = "libs"
4 HOMEPAGE = "http://sourceforge.net/projects/nxtcommand/"
5 AUTHOR = "Brian Bagnall <bbagnall at users.sourceforge.net>"
6
7 inherit java
8
9 SRC_URI = "\
10     svn://nxtcommand.svn.sourceforge.net/svnroot/nxtcommand;module=icommand-projects/trunk/icommand-bluez;rev=134;proto=https \
11     file://makefile.patch;patch=1 \
12     "
13
14 DEPENDS = "bluez-libs"
15
16 S = "${WORKDIR}/icommand-projects/trunk/icommand-bluez/Release"
17
18 do_compile() {
19   oe_runmake -f makefile clean
20   oe_runmake -f makefile all \
21     INCLUDES="-I${STAGING_INCDIR}/classpath " \
22     LIBS="-lbluetooth"
23 }
24
25 do_install() {
26   oe_libinstall -so libicmdbluez  ${D}${libdir_jni}
27 }
28
29 PACKAGES = "${PN}-jni ${PN}-jni-dbg"
30
31 RDEPENDS_${PN}-jni = "bluez-libs"
32
33 FILES_${PN}-jni = "${libdir_jni}/lib*.so"
34 FILES_${PN}-jni-dbg = "${libdir_jni}/.debug/lib*.so"