change usbtunerhelper src_uri.
[vuplus_openembedded] / recipes / ica / ica-bin_8.0.bb
1 # ica-bin OE build file
2 # Copyright (C) 2004-2006, Advanced Micro Devices, Inc.  All Rights Reserved
3 # Released under the MIT license (see packages/COPYING)
4
5 DEPENDS = "virtual/libx11 libxaw rpm2cpio-native"
6
7 HOMEPAGE="www.citrix.com/download/"
8
9 SRC_URI="file://${DL_DIR}/ICAClient-8.0-1.i386.rpm"
10
11 S="${WORKDIR}"
12 PACKAGES= "${PN}"
13 FILES_${PN} = "/"
14
15 python ica_do_fetch() {
16         import os
17         def dowarn(str,d):
18                 out = bb.data.expand(str, d)
19                 bb.note(out)
20
21         file = bb.data.getVar('A', d)
22         basen = os.path.basename(file)
23
24         if not os.path.exists(file):
25                 dowarn('You need to perform the following steps to build this package:',d)
26                 dowarn('Sign up at ${HOMEPAGE}',d)
27                 dowarn('- Download %s and place it in ${DL_DIR}' % basen,d)
28                 dowarn('- make this package again',d)
29                 raise bb.build.FuncFailed('Package not downloaded')
30 }
31
32 python do_fetch() {
33         bb.build.exec_func('ica_do_fetch', d)
34         bb.build.exec_func('base_do_fetch', d)
35 }
36
37 do_unpack() {
38         rpm2cpio.pl ${A} | cpio -i --make-directories
39 }
40
41 do_compile() {
42 }
43
44 DDIR="${D}/usr/lib/ICAClient"
45
46 do_install () {
47         for file in `find usr/lib/ICAClient/ -type d`; do
48                 install -d ${D}/$file
49         done
50
51         for file in `find usr/lib/ICAClient/ -type f`; do
52                 install $file ${D}/$file
53         done
54 }