Merge branch 'master' of git://dev.doredevelopment.dk/oe-micro into org.openembedded.dev
[vuplus_openembedded] / recipes / ica / ica-bin_10.6.bb
1 # ica-bin OE build file
2 # Copyright (C) 2004-2006, Advanced Micro Devices, Inc.  All Rights Reserved
3 # Released under the MIT license (see packages/COPYING)
4
5 DEPENDS = "virtual/libx11 libxaw rpm2cpio-native fakeroot-native"
6 RDEPENDS = "libxaw"
7
8 HOMEPAGE="www.citrix.com/download/"
9
10 SRC_URI="ftp://download2.citrix.com/FILES/en/products/Linux10/ICAClient-10.6-1.i386.rpm"
11
12 S="${WORKDIR}"
13 FILES_${PN} += "/"
14 FILES_${PN}-dbg += "/usr/lib/ICAClient/.debug"
15
16 do_configure() {
17         rpm2cpio.pl ${DL_DIR}/ICAClient-${PV}-1.i386.rpm | fakeroot cpio -i --make-directories
18 }
19
20 DDIR="${D}/usr/lib/ICAClient"
21
22 do_install () {
23         for file in `find usr/lib/ICAClient/ -type d`; do
24                 install -d ${D}/$file
25         done
26
27         for file in `find usr/lib/ICAClient/ -type f`; do
28                 install $file ${D}/$file
29         done
30 }