dvbapp : TranscodingSetup update
[vuplus_openembedded] / recipes / hping / hping2_1.9.9+2.0.0rc3.bb
1 DESCRIPTION = "hping is a command-line oriented TCP/IP packet \
2 assembler/analyzer. The interface is inspired to the ping(8) \
3 unix command, but hping isn't only able to send ICMP echo requests. \
4 It supports TCP, UDP, ICMP and RAW-IP protocols, has a traceroute \
5 mode, the ability to send files between a covered channel, and many \
6 other features."
7 HOMEPAGE = "http://www.hping.org/"
8 SECTION = "console/network"
9 LICENSE = "GPL"
10 PR = "r1"
11
12 SRC_URI = "http://www.hping.org/hping2.0.0-rc3.tar.gz \
13            file://hping2_debian.patch;patch=1 \
14            file://hping2_configure.patch;patch=1"
15 S = "${WORKDIR}/hping2-rc3"
16
17 #
18 # We've patched configure to accept byte order and ostype as env
19 # variables Pass those values in to stop it trying to figure it out
20 # by itself.
21 # NOTE: The configure script is not an autoconf script.
22 #
23 do_configure() {
24         # Additional flag based on target endiness (see siteinfo.bbclass)
25         BYTEORDER="${@base_conditional('SITEINFO_ENDIANESS', 'le', '__LITTLE_ENDIAN_BITFIELD', '__BIG_ENDIAN_BITFIELD', d)}"
26         oenote Determined byteorder as: $BYTEORDER
27         BYTEORDER="${BYTEORDER}" CONFIGOSTYPE="LINUX" ./configure
28 }
29
30 #
31 # Instead of patching the install we do things manually here
32 #
33 do_install() {
34         install -m 0755 -d ${D}${sbindir} ${D}/${mandir} ${D}${docdir}/hping2
35         install -m 0755 hping2 ${D}/${sbindir}
36         install -m 0644 docs/hping2.8 ${D}/${mandir}
37         install -m 0644 docs/HPING2-HOWTO.txt docs/HPING2-IS-OPEN \
38                 docs/MORE-FUN-WITH-IPID docs/SPOOFED_SCAN.txt \
39                 docs/AS-BACKDOOR docs/APD.txt ${D}${docdir}/hping2
40 }