Merge commit 'origin/opendreambox-1.6' into vuplus-1.6
[vuplus_openembedded] / recipes / hotplug-ng / hotplug-ng_002.bb
1 DESCRIPTION = "This collection of code replaces the existing linux-hotplug \
2 package with very tiny, compiled executable programs, instead of the \
3 existing bash scripts."
4 LICENSE = "GPL"
5 RPROVIDES_${PN} = "hotplug"
6 RCONFLICTS_${PN} = "hotplug"
7 RREPLACES_${PN} = "hotplug"
8
9 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/kernel/hotplug/hotplug-ng-${PV}.tar.gz"
10
11 #S = "${WORKDIR}/hotplug-ng-${PV}"
12
13 LD = "${CC}"
14 export HOSTCC = "${BUILD_CC}"
15 CFLAGS = " -I${S}/libsysfs/sysfs"
16 # Stripping should be done when _packaging_, not building
17 EXTRA_OEMAKE += "'STRIP=/bin/true'"
18
19 export etcdir = "${sysconfdir}"
20 export sbindir = "${base_sbindir}"
21 export bindir = "${base_bindir}"
22
23 do_install () {
24         oe_runmake 'DESTDIR=${D}' install
25 }