Merge branch 'opendreambox-1.6' into vuplus-1.6
[vuplus_openembedded] / recipes / hibernate-script / hibernate-script_1.12.bb
1 # hibernate-script OE build file
2 # Copyright (C) 2006, Advanced Micro Devices, Inc.  All Rights Reserved
3 # Released under the MIT license (see packages/COPYING)
4
5 DESCRIPTION="Hibernate script supporting multiple suspend methods"
6 LICENSE="GPL"
7 HOMEPAGE="http://www.suspend2.net"
8
9 SRC_URI="http://www.suspend2.net/downloads/all/${PN}-${PV}.tar.gz \
10         file://hibernate.conf \
11         file://standby.conf \
12         file://ram.conf"
13
14 inherit update-rc.d
15
16 INITSCRIPT_NAME = "hibernate-cleanup"
17 INITSCRIPT_PARAMS = "start 31 S ."
18
19 FILES_${PN}_append = " /usr/share/hibernate"
20
21 do_install () {
22         BASE_DIR=${D} PREFIX=/usr MAN_DIR=${D}/usr/share/man \
23                 ${S}/install.sh
24
25         ln -s ./hibernate ${D}/usr/sbin/hibernate-standby
26         ln -s ./hibernate ${D}/usr/sbin/hibernate-ram
27
28         #Override conf files from ${WORKDIR}
29         install -m 0644 ${WORKDIR}/hibernate.conf ${D}/etc/hibernate/
30         install -m 0644 ${WORKDIR}/ram.conf ${D}/etc/hibernate/
31         install -m 0644 ${WORKDIR}/standby.conf ${D}/etc/hibernate/
32
33         install -d ${D}/etc/init.d
34         install -m 0755 ${S}/init.d/hibernate-cleanup.sh ${D}/etc/init.d/hibernate-cleanup
35
36 }
37
38