Merge branch 'opendreambox-1.6' into vuplus-1.6
[vuplus_openembedded] / recipes / hal / hal_0.5.9.1.bb
1 DESCRIPTION = "Hardware Abstraction Layer"
2 HOMEPAGE = "http://freedesktop.org/Software/hal"
3 SECTION = "unknown"
4 LICENSE = "GPL LGPL AFL"
5
6 DEPENDS = "virtual/kernel dbus-glib udev intltool-native expat virtual/libusb0"
7 RDEPENDS_${PN} += "udev-utils hal-info"
8
9 PR = "r10"
10
11 SRC_URI = "http://freedesktop.org/~david/dist/hal-${PV}.tar.gz \
12            file://configure_fix.patch;patch=1 \
13            file://sg-inhibit.patch;patch=1 \
14            file://20hal \
15            file://99_hal"
16
17 S = "${WORKDIR}/hal-${PV}"
18
19 inherit autotools pkgconfig
20
21 EXTRA_OECONF = "--with-hwdata=${datadir}/hwdata \
22                 --with-expat=${STAGING_DIR_HOST}${layout_prefix} \
23                 --with-dbus-sys=${sysconfdir}/dbus-1/system.d \
24                 --with-hotplug=${sysconfdir}/hotplug.d \
25                 --disable-docbook-docs \
26                 --disable-policy-kit \
27                 --disable-acpi --disable-acpi-acpid --disable-acpi-proc \
28                 --disable-sonypic \
29                 --disable-pmu --disable-pci \
30                 --disable-pci-ids --disable-pnp-ids \
31                 "
32
33 do_install_append() {
34         install -d ${D}/etc/default/volatiles
35         install -m 0644 ${WORKDIR}/99_hal ${D}/etc/default/volatiles
36         install -d ${D}/etc/dbus-1/event.d
37         install -m 0755 ${WORKDIR}/20hal ${D}/etc/dbus-1/event.d
38 }
39
40 do_stage() {
41         autotools_stage_all
42         install -d ${STAGING_LIBDIR}
43         install -m 755 libhal/.libs/libhal.so.1.0.0 ${STAGING_LIBDIR}/libhal.so
44         install -m 755 libhal-storage/.libs/libhal-storage.so.1.0.0 ${STAGING_LIBDIR}/libhal-storage.so
45 }
46
47 # At the time the postinst runs, dbus might not be setup so only restart if running
48 pkg_postinst_hal () {
49         # can not do this offline
50         if [ "x$D" != "x" ]; then
51                 exit 1
52         fi
53
54         grep haldaemon /etc/group || addgroup haldaemon
55         grep haldaemon /etc/passwd || adduser --disabled-password --system --home /var/run/hald --no-create-home haldaemon --ingroup haldaemon -g HAL
56
57         /etc/init.d/populate-volatile.sh update
58
59         DBUSPID=`pidof dbus-daemon`
60
61         if [ "x$DBUSPID" != "x" ]; then
62                 /etc/init.d/dbus-1 reload
63         fi
64 }
65
66 pkg_postrm_hal () {
67         deluser haldaemon || true
68         delgroup haldaemon || true
69 }
70
71 PACKAGES =+ "libhal libhal-storage"
72
73 FILES_libhal = "${libdir}/libhal.so.*"
74 FILES_libhal-storage = "${libdir}/libhal-storage.so.*"
75
76 FILES_${PN} = "${sysconfdir} \
77                 ${bindir}/lshal \
78                 ${bindir}/hal-find-by-capability \
79                 ${bindir}/hal-find-by-property \
80                 ${bindir}/hal-device  \
81                 ${bindir}/hal-get-property \
82                 ${bindir}/hal-set-property  \
83                 ${bindir}/hal-lock  \
84                 ${bindir}/hal-is-caller-locked-out  \
85                 ${bindir}/hal-disable-polling  \
86                 ${sbindir} \
87                 ${libdir}/libhal.so.* \
88                 ${libdir}/libhal-storage.so.* \
89                 ${libdir}/hal \
90                 ${libexecdir} \
91                 ${datadir}/hal/fdi \
92                 ${datadir}/hal/scripts"