increase dvbapp PR.
[vuplus_openembedded] / recipes / gutenprint / gutenprint_5.1.3.bb
1 require gutenprint.inc
2
3 PR = "r1"
4
5 DEPENDS = "glib-2.0 ijs ncurses cups tiff jpeg libpng gutenprint-native espgs"
6
7 SRC_URI = "${SOURCEFORGE_MIRROR}/gimp-print/gutenprint-5.1.3.tar.bz2"
8 S = "${WORKDIR}/gutenprint-${PV}"
9
10
11 EXTRA_OECONF = "\
12                 --disable-nls \
13                  --disable-gtktest \
14 #               --enable-cups-ppds \
15 # this option is disabled here, since the ppds are generated during native build
16                  --disable-libgutenprintui \
17                  --disable-libgutenprintui2 \
18                 --disable-translated-cups-ppds \
19 #               --with-ghostscript \
20 # i MAY have to disable this one as well, since these are probably built in native as well
21                 --enable-cups-level3-ppds \
22                  --disable-gimptest \
23                 --enable-test \
24                 --enable-epson \
25                 --with-user-guide \
26                 --with-samples \
27                 --with-escputil \
28                  "                                 
29
30 do_configure() {
31         gnu-configize
32         libtoolize --force
33         oe_runconf
34 }
35
36
37 do_install_append() {
38         install -d ${D}${datadir}/cups/model/
39         install -m 644 ${STAGING_DATADIR_NATIVE}/cups/model/* ${D}${datadir}/cups/model/
40         cp -pPr ${D}${STAGING_LIBDIR}/* ${D}${libdir}/
41         cp -pPr ${D}${STAGING_DATADIR}/* ${D}${datadir}/
42 }
43
44
45 FILES_${PN} += "${datadir}/cups/model ${libdir}/cups ${datadir}/cups/calibrate.ppm"
46 FILES_${PN}-dbg += "${libdir}/cups/*/.debug"
47
48