Merge commit 'origin/opendreambox-1.6' into vuplus-1.6
[vuplus_openembedded] / recipes / guichan / guichan_0.7.1.bb
1 DESCRIPTION = "A portable C++ GUI library designed for games using Allegro, HGE, OpenGL, OpenLayer and/or SDL."
2 HOMEPAGE = "http://guichan.sourceforge.net"
3 DEPENDS = "virtual/libsdl libsdl-image"
4 PR = "r1"
5
6 SRC_URI = "http://guichan.googlecode.com/files/${PN}-${PV}.tar.gz \
7            file://link-against-sdlimage.patch;patch=1"
8
9 inherit autotools
10
11 EXTRA_OECONF = "--disable-opengl --disable-glut --disable-allegro \
12                 --enable-sdlimage --enable-sdl"
13
14 PACKAGES =+ "libguichan libguichan-sdl"
15
16 FILES_libguichan = "${libdir}/libguichan.so.*"
17 FILES_libguichan-sdl = "${libdir}/libguichan_sdl.so.*"
18
19 do_stage () {
20         autotools_stage_all
21 }
22