increase dvbapp PR.
[vuplus_openembedded] / recipes / gtk-engines / gtk-smooth-engine_0.5.8.bb
1 DESCRIPTION = "GTK theme engine Smooth"
2 SECTION = "x11/base"
3 PRIORITY = "optional"
4 LICENSE = "LGPL"
5 DEPENDS = "gtk+"
6 PR = "r1"
7
8 SRC_URI = "${SOURCEFORGE_MIRROR}/smooth-engine/${PN}-${PV}.tar.gz"
9
10 inherit autotools pkgconfig
11
12 python populate_packages_prepend() {
13         import os.path
14
15         engines_ver = ['gtk-2.0/', gtkbinver_find(d), '/engines']
16
17         engines_root = os.path.join(bb.data.getVar('libdir', d, 1), ''.join(engines_ver))
18         themes_root = os.path.join(bb.data.getVar('datadir', d, 1), "themes")
19
20         do_split_packages(d, engines_root, '^lib(.*)\.so$', 'gtk-engine-%s', 'GTK %s theme engine', extra_depends='')
21         do_split_packages(d, themes_root, '(.*)', 'gtk-theme-%s', 'GTK theme %s', allow_dirs=True, extra_depends='')
22 }