enigma2 : change vfd font (skin_user.xml)
[vuplus_openembedded] / recipes / gstreamer / gst-plugin-gles_git.bb
1 DESCRIPTION = "GStreamer OpenGL/GLES2 plugins"
2 LICENSE = "LGPL"
3
4 SRCREV = "18f5c4875006606b28aa9aa366abbc5dd1e16b60"
5
6 PR = "r1"
7 PR_append = "+gitr${SRCREV}"
8 PV = "0.10"
9
10 DEPENDS = "virtual/libsdl libgles-omap3 gstreamer gst-plugins-base"
11
12
13 SRC_URI = "git://anongit.freedesktop.org/gstreamer/gst-plugins-gl;protocol=git \
14            http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-0.10.23.tar.bz2 \
15            file://omap3_fix_renderbuffer_storage.patch;patch=1 \
16 "
17
18 S = "${WORKDIR}/git"
19
20 inherit autotools pkgconfig
21
22 EXTRA_OECONF = "--disable-tests --disable-examples"
23
24 do_configure_prepend () {
25         cp -rf ${WORKDIR}/gstreamer-0.10.23/common/* ${S}/common/
26         cp -rf ${WORKDIR}/gstreamer-0.10.23/po/* ${S}/po/
27         sed -i -e '/po /d' ${S}/Makefile.am
28 }
29
30 do_configure () {
31         #Hack to force GLES2
32         acl_cv_hardcode_libdir_flag_spec= ac_cv_header_GL_gl_h=no autotools_do_configure
33
34         #Hack to disable Werror (treat warning as errors)
35         for i in $(find "${S}" -name Makefile) ; do
36                 sed -i -e 's:-Wl,-rpath-link,${STAGING_LIBDIR}::g' -e s:\Werror\:\Wno-error\:g $i
37         done
38 }
39
40 GST_LIBV = 0.10
41
42 do_install() {
43         install -d ${D}${libdir}/gstreamer-${GST_LIBV}/
44         install -m 0755 gst/gl/.libs/libgstopengl.so ${D}${libdir}/gstreamer-${GST_LIBV}
45         install -m 0755 gst-libs/gst/gl/.libs/libgstgl-0.10.so.0.0.0 ${D}${libdir}/libgstgl-0.10.so.0
46 }
47
48
49 FILES_${PN} = "${libdir}/gstreamer-0.10/libgstopengl.so \
50                ${libdir}/libgstgl-0.10.so.0"
51
52 FILES_${PN}-dev += "\
53   ${libdir}/gstreamer-0.10/libgstopengl.* \
54 "
55
56 FILES_${PN}-dbg += "${libdir}/gstreamer-0.10/.debug"
57
58 INSANE_SKIP_${PN} = True
59