enigma2 : change vfd font (skin_user.xml)
[vuplus_openembedded] / recipes / gstreamer / gst-ffmpeg_0.10.8.bb
1 DESCRIPTION = "FFmpeg-based GStreamer plug-in"
2 SECTION = "multimedia"
3 PRIORITY = "optional"
4 LICENSE = "LGPL"
5 HOMEPAGE = "http://www.gstreamer.net/"
6 DEPENDS = "ffmpeg gstreamer gst-plugins-base zlib"
7
8 inherit autotools pkgconfig
9
10 SRC_URI = "http://gstreamer.freedesktop.org/src/${PN}/${PN}-${PV}.tar.bz2 \
11            file://lower-rank.diff;patch=1 \
12 "
13
14 PR = "r2"
15
16 FILES_${PN} += "${libdir}/gstreamer-0.10/*.so"
17 FILES_${PN}-dbg += "${libdir}/gstreamer-0.10/.debug"
18 FILES_${PN}-dev += "${libdir}/gstreamer-0.10/*.la ${libdir}/gstreamer-0.10/*.a"
19
20 EXTRA_OECONF = " --with-system-ffmpeg "
21
22 # We do this because the install program is called with -s which causes it to
23 # call "strip" and it then mangles cross compiled stuff..
24 PATH_prepend="${CROSS_DIR}/${TARGET_SYS}/bin:"
25
26 # Hack to get STAGING_LIBDIR into the linker path when building ffmpeg
27 CC = "${CCACHE} ${HOST_PREFIX}gcc ${TARGET_CC_ARCH} -L${STAGING_LIBDIR}"
28