increase dvbapp PR.
[vuplus_openembedded] / recipes / gstreamer / gst-ffmpeg_0.10.4.bb
1 DESCRIPTION = "FFmpeg-based GStreamer plug-in"
2 SECTION = "multimedia"
3 PRIORITY = "optional"
4 LICENSE = "LGPL"
5 HOMEPAGE = "http://www.gstreamer.net/"
6 DEPENDS = "ffmpeg gstreamer gst-plugins-base zlib"
7 PR = "r7"
8
9 inherit autotools pkgconfig
10
11 SRC_URI = "http://gstreamer.freedesktop.org/src/${PN}/${PN}-${PV}.tar.bz2 \
12            file://configure-hack.diff;patch=1 \
13 "
14
15 FILES_${PN} += "${libdir}/gstreamer-0.10/*.so"
16 FILES_${PN}-dbg += "${libdir}/gstreamer-0.10/.debug"
17 FILES_${PN}-dev += "${libdir}/gstreamer-0.10/*.la ${libdir}/gstreamer-0.10/*.a"
18
19 EXTRA_OECONF = "--disable-sdltest --disable-ffplay --disable-freetypetest \
20                 --disable-vorbis --disable-vorbistest --disable-encoders \
21                 --disable-v4l --disable-audio-oss --disable-dv1394 \
22                 --disable-vhook --with-system-ffmpeg --disable-ffserver \
23                 --enable-pp --disable-decoder-vorbis"
24
25 # We do this because the install program is called with -s which causes it to
26 # call "strip" and it then mangles cross compiled stuff..
27 PATH_prepend="${CROSS_DIR}/${TARGET_SYS}/bin:"
28
29 # Hack to get STAGING_LIBDIR into the linker path when building ffmpeg
30 CC = "${CCACHE} ${HOST_PREFIX}gcc ${TARGET_CC_ARCH} -L${STAGING_LIBDIR}"
31