dvbapp : TranscodingSetup update
[vuplus_openembedded] / recipes / grep / grep_2.5.1.bb
1 LICENSE = "GPL"
2 SECTION = "console/utils"
3 DESCRIPTION = "grep GNU utility"
4 PR = "r2"
5
6 SRC_URI = "${GNU_MIRROR}/grep/grep-${PV}.tar.bz2 \
7            file://uclibc-fix.patch;patch=1"
8
9 inherit autotools
10
11 EXTRA_OECONF = "--disable-perl-regexp --disable-ncurses"
12
13 do_configure () {
14         rm -f ${S}/m4/init.m4
15         autotools_do_configure
16 }
17
18 do_install () {
19         autotools_do_install
20         install -d ${D}${base_bindir}
21         mv ${D}${bindir}/grep ${D}${base_bindir}/grep.${PN}
22         mv ${D}${bindir}/egrep ${D}${base_bindir}/egrep.${PN}
23         mv ${D}${bindir}/fgrep ${D}${base_bindir}/fgrep.${PN}
24 }
25
26
27 pkg_postinst_${PN} () {
28         update-alternatives --install ${base_bindir}/grep grep grep.${PN} 100
29         update-alternatives --install ${base_bindir}/egrep egrep egrep.${PN} 100
30         update-alternatives --install ${base_bindir}/fgrep fgrep fgrep.${PN} 100
31 }
32
33 pkg_prerm_${PN} () {
34         update-alternatives --remove grep grep.${PN}
35         update-alternatives --remove egrep egrep.${PN}
36         update-alternatives --remove fgrep fgrep.${PN}
37 }