increase dvbapp PR.
[vuplus_openembedded] / recipes / gnuchess / fltk-chess_0.51.bb
1 DESCRIPTION = "fltk-chess is a frontend for the Gnuchess chess playing engine."
2 AUTHOR = "Andreas Holzer <a.holzer@cheese.at>"
3 SECTION = "x11/games"
4 PRIORITY = "optional"
5 LICENSE = "GPL"
6 DEPENDS = "fltk"
7 RDEPENDS = "gnuchess"
8
9
10 SRC_URI = "http://members.cheese.at/woody/zaurus/src/fltk-chess-${PV}.tgz"
11 S = "${WORKDIR}/fltk-chess/"
12
13
14 do_compile() {
15         `fltk-config --cxx --cxxflags --ldflags --use-images` -o fltk-chess \
16          fltk-chess.cxx
17 }
18
19 do_install() {
20         install -d ${D}${bindir}
21         install -d ${D}${datadir}/pixmaps/fltk-chess/
22         install -d ${D}${datadir}/applications/
23         install -m 0755 ${S}/fltk-chess ${D}${bindir}
24         install -m 0644 ${S}/bitmaps/*.pnx ${D}${datadir}/pixmaps/fltk-chess/
25         install -m 0644 ${S}/bitmaps/{user,computer}.png \
26                 ${D}${datadir}/pixmaps/fltk-chess/
27         install -m 0644 ${S}/bitmaps/fltk-chess.png  ${D}${datadir}/pixmaps/
28         install -m 0644 ${S}/fltk-chess.desktop  ${D}${datadir}/applications/
29 }