support manual-nameserver.
[vuplus_openembedded] / recipes / gnome / libproxy_0.2.3.bb
1 DESCRIPTION = "A library handling all the details of proxy configuration"
2 LICENSE = "LGPL"
3 DEPENDS = "libxmu gconf virtual/libx11"
4
5 PR = "r1"
6
7 SRC_URI = "http://libproxy.googlecode.com/files/libproxy-${PV}.tar.gz \
8            file://libproxy-move-define-__USE_BSD.patch;patch=1 \
9            "
10
11 inherit autotools_stage
12
13 # Disable plugins that are *up* in the depchain, they need libproxy to build
14 # Don't we just love circular deps?
15 EXTRA_OECONF = " --with-file \
16                  --with-gnome \
17                  --without-kde \
18                  --without-webkit \
19                  --without-mozjs \
20                  --without-networkmanager \
21                 "
22
23 FILES_${PN}-dbg += "${libdir}/libproxy/*/plugins/.debug"
24