increase dvbapp PR.
[vuplus_openembedded] / recipes / gnome / libbonoboui_2.14.0.bb
1 LICENSE = "GPL"
2 SECTION = "x11/gnome/libs"
3 PR = "r1"
4
5 inherit gnome pkgconfig
6
7 FILES_${PN} += "${libdir}/libglade/2.0/*.so"
8 FILES_${PN}-dev += "${libdir}/libglade/2.0/* ${datadir}/gnome-2.0/ui \
9         ${libdir}/bonobo-2.0/samples"
10 FILES_${PN}-dbg += "${libdir}/bonobo-2.0/samples/.debug \
11         ${libdir}/libglade/2.0/.debug"
12
13 DEPENDS = "libgnomecanvas libbonobo libgnome glib-2.0 gtk-doc gconf libxml2 libglade"
14
15 EXTRA_OECONF = "--disable-gtk-doc"
16
17 HEADERS = " \
18 bonobo/bonobo-zoomable.h \
19 bonobo/bonobo-ui-component.h \
20 bonobo/bonobo-dock-layout.h \
21 bonobo/bonobo-ui-type-builtins.h \
22 bonobo/bonobo-canvas-component.h \
23 bonobo/bonobo-widget.h \
24 bonobo/bonobo-ui-engine.h \
25 bonobo/bonobo-window.h \
26 bonobo/bonobo-ui-toolbar.h \
27 bonobo/bonobo-dock-band.h \
28 bonobo/bonobo-ui-toolbar-item.h \
29 bonobo/bonobo-control.h \
30 bonobo/bonobo-dock-item.h \
31 bonobo/bonobo-ui-config-widget.h \
32 bonobo/bonobo-zoomable-frame.h \
33 bonobo/bonobo-control-frame.h \
34 bonobo/bonobo-dock.h \
35 bonobo/bonobo-ui-main.h \
36 bonobo/bonobo-canvas-item.h \
37 bonobo/bonobo-ui-node.h \
38 bonobo/bonobo-socket.h \
39 bonobo/bonobo-selector.h \
40 bonobo/bonobo-ui-sync.h \
41 bonobo/bonobo-ui-util.h \
42 bonobo/bonobo-plug.h \
43 bonobo/bonobo-ui-toolbar-button-item.h \
44 bonobo/bonobo-ui-toolbar-toggle-button-item.h \
45 bonobo/bonobo-ui-container.h \
46 bonobo/bonobo-file-selector-util.h \
47 bonobo/bonobo-property-control.h \
48 bonobo/bonobo-selector-widget.h \
49 libbonoboui.h \
50 bonobo.h \
51 "
52
53 do_stage() {
54         install -d ${STAGING_INCDIR}/libbonoboui-2.0/bonobo
55         for i in ${HEADERS}; do
56                 install -m 0644 $i ${STAGING_INCDIR}/libbonoboui-2.0/$i
57         done
58         oe_libinstall -C bonobo -a -so libbonoboui-2 ${STAGING_LIBDIR}
59 }