increase dvbapp PR.
[vuplus_openembedded] / recipes / gnome / goffice_0.7.14.bb
1 DESCRIPTION="Gnome Office Library"
2 LICENSE="GPLv2"
3
4 PR = "r2"
5
6 DEPENDS="glib-2.0 gtk+ pango cairo libgnomeprint libgsf libglade libpcre libxml2 libart-lgpl"
7
8 inherit gnome pkgconfig
9
10 SRC_URI += " file://c99math.patch;patch=1 \
11              file://nodolt.patch;patch=1 "
12
13 do_stage() {
14         autotools_stage_all
15 }
16
17 FILES_${PN}-dbg += "${libdir}/goffice/${PV}/plugins/*/.debug"
18
19 RRECOMMENDS_${PN} = " \
20   goffice-plugin-plot-barcol \
21   goffice-plugin-plot-distrib \
22   goffice-plugin-plot-pie \
23   goffice-plugin-plot-radar \
24   goffice-plugin-plot-surface \
25   goffice-plugin-plot-xy \
26   goffice-plugin-reg-linear \
27   goffice-plugin-reg-logfit \
28   goffice-plugin-smoothing \
29 "
30
31 FILES_${PN} = "${bindir}/* ${sbindir}/* ${libexecdir}/* ${libdir}/lib*${SOLIBS} \
32             ${sysconfdir} ${sharedstatedir} ${localstatedir} \
33             ${base_bindir}/* ${base_sbindir}/* \
34             ${base_libdir}/*${SOLIBS} \
35             ${datadir}/${PN} \
36             ${datadir}/pixmaps ${datadir}/applications \
37             ${datadir}/idl ${datadir}/omf ${datadir}/sounds \
38             ${libdir}/bonobo/servers"
39
40 PACKAGES_DYNAMIC = "goffice-plugin-*"
41
42 python populate_packages_prepend () {
43         goffice_libdir = bb.data.expand('${libdir}/goffice/${PV}/plugins/', d)
44
45         do_split_packages(d, goffice_libdir, '(.*)', 'goffice-plugin-%s', 'Goffice plugin for %s', allow_dirs=True)
46 }
47