increase dvbapp PR.
[vuplus_openembedded] / recipes / gnome / gnome-session_2.28.0.bb
1 DESCRIPTION = "Gnome session manager"
2 LICENSE = "GPL"
3 SECTION = "x11/gnome"
4 DEPENDS = "devicekit-power libwnck gnome-keyring libgnomeui startup-notification gtk+ gconf gdk-pixbuf-csource-native"
5
6 inherit gnome 
7
8 EXTRA_OECONF = " ac_cv_path_GCONF_SANITY_CHECK=set "
9
10 do_configure_append() {
11         for i in $(find ${S} -name "Makefile") ; do
12                 sed -i -e s:"GCONFTOOL = .*/usr/bin/gconftool-2":"GCONFTOOL = /usr/bin/gconftool-2":g $i
13                 sed -i -e s:"GCONF_SANITY_CHECK = set":"GCONF_SANITY_CHECK = /usr/libexec/gconf-sanity-check-2":g $i
14         done    
15 }
16
17 do_stage () {
18          autotools_stage_all
19 }
20
21 FILES_${PN} += "${datadir}/xsessions ${datadir}/icons ${datadir}/gnome ${libdir}/gnome-session/helpers"
22 FILES_${PN}-dbg += "${libdir}/gnome-session/helpers/.debug"
23