increase dvbapp PR.
[vuplus_openembedded] / recipes / gnome / gnome-keyring_2.28.2.bb
1 DESCRIPTION = "GNOME security credential management"
2 LICENSE = "GPL"
3 SECTION = "x11/gnome"
4 DEPENDS = " gtk+-native libpam gconf gtk+ libtasn1 libtasn1-native libgcrypt"
5
6 inherit gnome pkgconfig
7
8 EXTRA_OECONF = "--disable-gtk-doc --enable-pam --with-pam-dir=${libdir}/security/"
9
10 SRC_URI += "file://tasn.m4 file://org.gnome.keyring.service"
11
12 do_configure_prepend() {
13         cp ${WORKDIR}/tasn.m4 acinclude.m4
14 }
15
16 do_install_append () {
17         install -d ${D}${datadir}/dbus-1/services
18         install -m 0644 ${WORKDIR}/org.gnome.keyring.service ${D}${datadir}/dbus-1/services
19 }
20
21 FILES_${PN} += "${datadir}/dbus-1/services ${datadir}/gcr"
22 PACKAGES =+ "gnome-keyring-pam-plugin"
23 FILES_gnome-keyring-pam-plugin = "${libdir}/security/*.so"
24 FILES_${PN}-dbg += "${libdir}/gnome-keyring/*/.debug ${libdir}/security/.debug"
25