increase dvbapp PR.
[vuplus_openembedded] / recipes / gnash / gnash_0.8.5.bb
1 require gnash.inc
2
3 DEPENDS += "gst-plugins-base cairo"
4
5 acpaths = " -Imacros"
6
7 DEFAULT_PREFERENCE = "-1"
8 DEFAULT_PREFERENCE_angstrom = "1"
9
10 # Boost lacks defines for lots of archs
11 TARGET_CC_ARCH_append = " -I${STAGING_INCDIR}/libxml2 -DHAVE_POLL_H ${@[' -D_BIG_ENDIAN', ' -D_LITTLE_ENDIAN'][bb.data.getVar('SITEINFO_ENDIANESS', d, 1) == 'le']}"
12
13
14 do_configure_prepend() {
15         # fix an upstream case-typo in the configure script
16         sed -i s:Media_handler:media_handler:g ${S}/configure.ac
17         sed -i -e 's:GNASH_PKG_FIND(libpng:GNASH_PKG_FIND(png:g' ${S}/configure.ac
18         for i in $(find ${S} -name "Makefile.am") ; do  
19                 sed -i -e s:LIBPNG:PNG:g $i
20         done
21         export CFLAGS="${CFLAGS} -lpng"
22 }
23
24 do_install_append() {
25         oe_runmake DESTDIR=${D} install-plugin
26 }
27
28
29 EXTRA_OECONF += " --without-included-ltdl \
30                   --with-ltdl-include=${STAGING_INCDIR} \
31                   --with-ltdl-lib=${STAGING_LIBDIR} \
32                   --enable-plugins \
33                   --enable-npapi \
34                   --with-npapi-plugindir=${libdir}/mozilla/plugins \
35                   --enable-mit-shm \
36                   --enable-png \
37                   --with-png-incl=${STAGING_INCDIR} \
38                   --with-png-lib=${STAGING_LIBDIR} \
39                   --with-cairo-incl=${STAGING_DIR_HOST}/usr/include/cairo \
40                   --with-cairo-lib=${STAGING_DIR_HOST}/usr/lib \
41                   --enable-media=gst \
42                   --disable-speex \
43                   --disable-speexdsp \
44                 "
45