Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into...
[vuplus_openembedded] / recipes / glibc / glibc_2.3.2+cvs20040726.bb
1 require glibc.inc
2
3 DEFAULT_PREFERENCE_sh3 = "-99"
4
5 FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/glibc-cvs"
6 PR = "r31"
7
8 GLIBC_ADDONS ?= "linuxthreads"
9
10 #          file://noinfo.patch;patch=1
11 #          file://ldconfig.patch;patch=1;pnum=0
12 SRC_URI = "cvs://anoncvs@sources.redhat.com/cvs/glibc;module=libc;date=${@bb.data.getVar('PV', d, 1)[9:]} \
13            file://arm-ioperm.patch;patch=1;pnum=0 \
14            file://makeconfig.patch;patch=1;pnum=0 \
15            file://ldd.patch;patch=1;pnum=0 \
16            file://fhs-linux-paths.patch;patch=1 \
17            file://arm-no-hwcap.patch;patch=1;pnum=0 \
18            file://arm-memcpy.patch;patch=1;pnum=0 \
19            file://arm-longlong.patch;patch=1;pnum=0 \
20            file://arm-machine-gmon.patch;patch=1;pnum=0 \
21            file://glibc-fp-byteorder.patch;patch=1 \
22            \
23            file://etc/ld.so.conf \
24            file://generate-supported.mk"
25
26 # seems to fail on tls platforms
27 SRC_URI_append_arm = " file://dyn-ldconfig.patch;patch=1;pnum=0"
28
29 SRC_URI_append_openmn = " file://ldsocache-varrun.patch;patch=1"
30
31 S = "${WORKDIR}/libc"
32 B = "${WORKDIR}/build-${TARGET_SYS}"
33
34 RDEPENDS_${PN}-dev = "linux-libc-headers-dev"
35 RPROVIDES_${PN}-dev += "libc-dev virtual-libc-dev"
36
37 EXTRA_OECONF = "--enable-kernel=${OLDEST_KERNEL} \
38                 --without-cvs --disable-profile --disable-debug --without-gd \
39                 --enable-clocale=gnu \
40                 --enable-add-ons=${GLIBC_ADDONS} \
41                 --with-headers=${STAGING_INCDIR} \
42                 ${GLIBC_EXTRA_OECONF}"
43
44 do_configure () {
45 # override this function to avoid the autoconf/automake/aclocal/autoheader
46 # calls for now
47 # don't pass CPPFLAGS into configure, since it upsets the kernel-headers
48 # version check and doesn't really help with anything
49         if [ -z "`which rpcgen`" ]; then
50                 echo "rpcgen not found.  Install glibc-devel."
51                 exit 1
52         fi
53         (cd ${S} && gnu-configize) || die "failure in running gnu-configize"
54         CPPFLAGS="" oe_runconf
55 }
56
57 rpcsvc = "bootparam_prot.x nlm_prot.x rstat.x \
58           yppasswd.x klm_prot.x rex.x sm_inter.x mount.x \
59           rusers.x spray.x nfs_prot.x rquota.x key_prot.x"
60
61 do_compile () {
62         # this really is arm specific
63         touch ${S}/sysdeps/arm/framestate.c
64         # -Wl,-rpath-link <staging>/lib in LDFLAGS can cause breakage if another glibc is in staging
65         unset LDFLAGS
66         base_do_compile
67         (
68                 cd ${S}/sunrpc/rpcsvc
69                 for r in ${rpcsvc}; do
70                         h=`echo $r|sed -e's,\.x$,.h,'`
71                         rpcgen -h $r -o $h || oewarn "unable to generate header for $r"
72                 done
73         )
74 }
75
76 require glibc-stage.inc
77
78 require glibc-package.bbclass