dvbapp : TranscodingSetup update
[vuplus_openembedded] / recipes / gizmod / gizmod_2.3.bb
1 DESCRIPTION = "Gizmo Daemon"
2 HOMEPAGE = "http://gizmod.sourceforge.net"
3 LICENSE = "GPLv2"
4 SECTION = "console/multimedia"
5 DEPENDS = "python virtual/libx11 xf86vidmodeproto alsa-lib"
6 SRC_URI = "${SOURCEFORGE_MIRROR}/gizmod/gizmod-${PV}.tar.bz2 \
7            file://disable-xmms.patch;patch=1 \
8            file://fix-python-configure.patch;patch=1 \
9            file://disable-bmp.patch;patch=1"
10
11 PR = "r0"
12
13 inherit autotools
14
15 EXTRA_OECONF = "--disable-xmms --disable-bmp --disable-xosd"
16
17 #do_configure_prepend() {
18 #    sed -i 's/TARGET_SYS/${TARGET_SYS}/' ${S}/configure.ac
19 #}
20
21 FILES_${PN} += "${datadir}/gizmo/scripts ${datadir}/gizmo/plugins/*.so ${datadir}/gizmo/plugins/*.so.*"
22 FILES_${PN}-dev += "${datadir}/gizmo/plugins/*.a ${datadir}/gizmo/plugins/*.la"
23 FILES_${PN}-dbg += "${datadir}/gizmo/plugins/.debug"