add plugin(streamtvplayer)
[vuplus_openembedded] / recipes / giac / giac_0.8.4.bb
1 DESCRIPTION = "A free computer algebra system"
2 HOMEPAGE = "http://www-fourier.ujf-grenoble.fr/~parisse/giac.html"
3 SECTION = "console/utils"
4 PRIORITY = "optional"
5 LICENSE = "GPL"
6 DEPENDS = "fltk gmp mpfr gsl"
7
8 SRC_URI = "ftp://ftp-fourier.ujf-grenoble.fr/xcas/giac-${PV}.tar.gz"
9
10 inherit autotools
11
12 PARALLEL_MAKE = ""
13
14 TARGET_CC_ARCH += "${LDFLAGS}"
15
16 do_configure() {
17         sed -i -e s:doc::g ${S}/Makefile.am
18         oe_runconf
19         sed -i -e s:doc::g ${S}/Makefile
20 }
21
22 do_install () {
23         oe_runmake prefix="${D}${prefix}" \
24                 bindir="${D}${bindir}" \
25                 libdir="${D}${libdir}" \
26                 includedir="${D}${includedir}" \
27                 install
28 }
29
30 PACKAGES += " libgiac libxcas"
31
32 FILES_${PN} = "${bindir} \
33                ${datadir}/${PN} \
34                ${datadir}/application* \
35                ${datadir}/pixmaps \
36 "
37
38 FILES_libgiac = "${libdir}/libg*.so.*"
39 FILES_libxcas = "${libdir}/libx*.so.*"