update driver
[vuplus_openembedded] / recipes / geoclue / geoclue_git.bb
1 DESCRIPTION = "GeoClue is a project that provide all kinds of geography information to an application"
2 HOMEPAGE = "http://www.freedesktop.org/wiki/Software/GeoClue"
3
4 DEPENDS = "libgpsmgr libgpsbt gtk+ gypsy libxml2 gconf libsoup dbus-glib"
5
6 SRCREV = "3a31d260074397a968afaf1065856ab763befb01"
7 PV = "0.11.1"
8 PR = "r1"
9 PR_append = "+gitr${SRCREV}"
10 PE = "1"
11
12 inherit gnome autotools_stage
13
14 SRC_URI = "git://anongit.freedesktop.org/git/geoclue;protocol=git \
15            file://gtk-doc.make"
16
17 S = "${WORKDIR}/git"
18
19
20 LDFLAGS_append = " -lgthread-2.0 "
21
22 EXTRA_OECONF = " \
23                  --enable-system-bus"
24
25 do_configure_prepend() {
26         cp ${WORKDIR}/gtk-doc.make ${S}
27 }
28
29
30 FILES_${PN} += " \
31                    ${datadir}/geoclue-providers/ \
32            ${datadir}/dbus-1"