increase dvbapp PR.
[vuplus_openembedded] / recipes / gdal / gdal_1.5.2.bb
1 DESCRIPTION = "GDAL is a translator library for raster geospatial data formats"
2 HOMEPAGE = "http://www.gdal.org/"
3 LICENSE = "MIT"
4 DEPENDS = "proj-4 sqlite3 zlib jpeg libpng tiff giflib curl jasper expat"
5 PR = "r2"
6
7 SRC_URI = "http://www.gdal.org/dl/${P}.tar.gz \
8            file://gdal_config.patch;patch=1 \
9           "
10
11 ARM_INSTRUCTION_SET = "arm"
12
13 inherit autotools binconfig
14
15 EXTRA_OECONF = "--without-perl \
16                 --without-python \
17                 --without-php \
18                 --without-ruby \
19                 --with-libz=${STAGING_DIR_TARGET} \
20                 --with-png=${STAGING_DIR_TARGET} \
21                 --with-jpeg=${STAGING_DIR_TARGET} \
22                 --with-libtiff=${STAGING_DIR_TARGET} \
23                 --with-gif=${STAGING_DIR_TARGET} \
24                 --with-jasper=${STAGING_DIR_TARGET} \
25                 --with-expat=${STAGING_DIR_TARGET} \
26                 --with-expat-inc=${STAGING_INCDIR} \
27                 --with-expat-lib=${STAGING_LIBDIR} \
28 "
29
30 # GDAL clutter /usr/share with files instead of using a subdir :(
31 FILES_${PN}-dev += "${datadir}"
32
33 do_compile() {
34         oe_runmake default
35 }
36
37 do_stage() {
38         autotools_stage_all
39 }       
40