Merge branch 'opendreambox' of git://git.opendreambox.org/git/openembedded into opend...
[vuplus_openembedded] / recipes / gchub / gchub-module_svn.bb
1 SECTION = "base"
2 PRIORITY = "optional"
3 DESCRIPTION = "Kernel module for the GameCube Hub input device"
4 DEPENDS = "virtual/kernel"
5 LICENSE = "GPL"
6 PV = "1:0.0+svn${SRCDATE}"
7
8 SRC_URI = "svn://svn.navi.cx/misc/trunk/wasabi/devices;module=gchub;proto=http"
9
10 S = "${WORKDIR}/gchub/kernel"
11
12 inherit module
13
14 do_install() {
15         install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/usb
16         install gchub.ko -m 0644 ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/usb/gchub.ko
17 }