increase dvbapp PR.
[vuplus_openembedded] / recipes / gammu / gammu_1.26.1.bb
1 DESCRIPTION = "GNU All Mobile Managment Utilities"
2 SECTION = "console/network"
3 DEPENDS = "bluez-libs cmake-native python mysql"
4 RDEPENDS_python-${PN} = "python-core"
5 LICENSE = "GPL"
6 HOMEPAGE = "http://www.gammu.org/"
7 PR = "r0"
8
9 SRC_URI = "http://dl.cihar.com/gammu/releases/gammu-${PV}.tar.bz2"
10
11 inherit distutils-common-base cmake
12
13 PYTHON_DIR = "${@python_dir(d)}"
14
15 do_configure() {
16     cd ${S}
17     sed -i 's@^cmake [^$]*\$@cmake -DCMAKE_FIND_ROOT_PATH=${STAGING_DIR_TARGET} $@' configure
18     sed -i 's@\${PYTHON_SITEDIR}@${libdir}/${PYTHON_DIR}/site-packages@g' python/gammu/CMakeLists.txt
19     ./configure --prefix=${prefix} --enable-shared --enable-backup
20 }
21
22 do_stage() {
23     autotools_stage_all
24 }
25
26 # gammu has a non-standard uninstalled .pc file, which confuses pkgconfig.bbclass.
27 # Replace it by custom do_stage_append():
28 #do_stage_append () {
29 #       install -d ${PKG_CONFIG_DIR}
30 #       cat build-configure/cfg/gammu.pc > ${PKG_CONFIG_DIR}/gammu.pc
31 #}
32
33 PACKAGES =+ "${PN}-smsd libgammu libgsmsd python-${PN}"
34
35 FILES_${PN} = "${bindir}/gammu ${bindir}/jadmaker ${sysconfdir}/bash_completion.d/gammu"
36 FILES_${PN}-smsd = "${bindir}/gammu-smsd*"
37 FILES_${PN}-dev += "${bindir}/gammu-config ${libdir}/*.so"
38 FILES_${PN}-dbg += "${bindir}/.debug ${libdir}/.debug ${libdir}/python*/site-packages/gammu/.debug"
39 FILES_libgammu = "${libdir}/libGammu.so.*"
40 FILES_libgsmsd = "${libdir}/libgsmsd.so.*"
41 FILES_python-${PN} = "${libdir}/${PYTHON_DIR}/site-packages/gammu/*.??"