increase dvbapp PR.
[vuplus_openembedded] / recipes / gallery / gallery_1.5.5.bb
1 DESCRIPTION = "The Gallery v1 web image gallery"
2 SECTION = "apps"
3 LICENSE = "GPL"
4 RDEPENDS = "apache2 modphp imagemagick jhead"
5 PR = "r2"
6
7 SRC_URI = "http://{SOURCEFORGE_MIRROR}/sourceforge/gallery/gallery-${PV}-pl1.tar.gz"
8
9 S = "${WORKDIR}/gallery"
10
11 inherit autotools
12
13 HTTPCONF = "${sysconfdir}/apache2/httpd.conf"
14 DEST_DIR = "${datadir}/apache2/htdocs/"
15
16 #
17 # don't list the albums as a file - it might get auto-deleted
18 #
19 FILES_${PN} = "${DEST_DIR}/gallery ${sysconfdir}/apache2/modules.d"
20
21
22 # No configure step for gallery
23 do_configure() {
24         :
25 }
26
27 # No compile step either
28 do_compile() {
29         :
30 }
31
32 #
33 do_install() {
34         mkdir -p ${D}/${DEST_DIR} ${D}${sysconfdir}/apache2/modules.d
35         cp -pPR ${S} ${D}/${DEST_DIR}
36         cp ${FILESDIR}/gallery.conf  ${D}${sysconfdir}/apache2/modules.d/95_gallery.conf
37 }
38
39 # remove the gallery code, but not the albums!
40 pkg_postrm_${PN}() {
41         rm -rf ${DEST_DIR}/gallery /${sysconfdir}/apache2/modules.d/95_gallery.conf
42 }