increase dvbapp PR.
[vuplus_openembedded] / recipes / freetype / freetype_2.3.6.bb
1 DESCRIPTION = "Freetype font rendering library"
2 SECTION = "libs"
3 LICENSE = "freetype"
4 PR = "r0"
5
6 SRC_URI = "\
7   ${SOURCEFORGE_MIRROR}/freetype/freetype-${PV}.tar.bz2 \
8   file://no-hardcode.patch;patch=1 \
9   file://fix-configure.patch;patch=1 \
10   file://libtool-tag.patch;patch=1 \
11 "
12 S = "${WORKDIR}/freetype-${PV}"
13
14 inherit autotools pkgconfig binconfig
15
16 LIBTOOL = "${HOST_SYS}-libtool"
17 EXTRA_OEMAKE = "'LIBTOOL=${LIBTOOL}'"
18 EXTRA_OECONF = "--without-zlib"
19
20 do_configure() {
21         cd builds/unix
22         libtoolize --force --copy
23         gnu-configize --force
24         aclocal -I .
25         autoconf
26         cd ${S}
27         oe_runconf
28 }
29
30 do_compile_prepend() {
31         ${BUILD_CC} -o objs/apinames src/tools/apinames.c
32 }
33
34 do_stage() {
35      export LIBTOOL='${LIBTOOL}'
36          autotools_stage_all
37          oe_libinstall -so -a -C objs libfreetype ${STAGING_LIBDIR}
38 }
39
40 FILES_${PN} = "${libdir}/lib*.so.*"
41 FILES_${PN}-dev += "${bindir}"