increase dvbapp PR.
[vuplus_openembedded] / recipes / freetype / freetype_2.0.9.bb
1 SECTION = "libs"
2 LICENSE = "freetype"
3 DESCRIPTION = "Freetype font rendering library"
4
5 SRC_URI = "${SOURCEFORGE_MIRROR}/freetype/freetype-${PV}.tar.bz2 \
6            file://install.mk.patch;patch=1"
7
8 FILES_${PN} = "${libdir}/lib*.so.*"
9 FILES_${PN}-dev += " ${bindir}"
10
11 inherit autotools  pkgconfig
12
13 LIBTOOL = "${S}/builds/unix/${HOST_SYS}-libtool"
14 EXTRA_OEMAKE = "'LIBTOOL=${LIBTOOL}'"
15
16 do_configure () {
17         cd builds/unix
18         libtoolize --force
19         gnu-configize
20         aclocal -I .
21         autoconf
22         cd ${S}
23         oe_runconf
24 }
25
26 do_stage () {
27         oe_libinstall -so -a -C objs libfreetype ${STAGING_LIBDIR}
28
29         cp -a ${S}/include/*.h ${STAGING_INCDIR}
30         install -d ${STAGING_INCDIR}/freetype2
31         cp -a ${S}/include/freetype ${STAGING_INCDIR}/freetype2/
32
33         sed -e 's,${prefix},${STAGING_LIBDIR}/..,' < builds/unix/freetype-config > ${STAGING_BINDIR_CROSS}/freetype-config
34         chmod u+x ${STAGING_BINDIR_CROSS}/freetype-config
35 }