dvbapp : TranscodingSetup update
[vuplus_openembedded] / recipes / freesmartphone / opimd-utils_git.bb
1 DESCRIPTION = "Test scripts for freesmartphone.org opimd interface"
2 HOMEPAGE = "http://freesmartphone.org"
3 SHR_RELEASE ?= "shr"
4 LICENSE ?= "GPL"
5 RDEPENDS = "python-elementary python-dbus python-codecs python-shell python python-core python-edbus frameworkd"
6 SECTION = "x11/application"
7 PV = "0.0.2+gitr${SRCREV}"
8 PR = "r0"
9
10 inherit setuptools
11
12 PACKAGES =+ "\
13   ${PN}-cli \
14   ${PN}-notes \
15   ${PN}-data \
16 "
17
18 RDEPENDS_${PN} = "\
19   ${PN}-data \
20   shr-settings \
21   pyphonelog \
22   shr-theme \
23 "
24
25 RDEPENDS_${PN}-notes = "\
26   ${PN}-data \
27 "
28
29 RRECOMMENDS_${PN} = "\
30   ${PN}-notes \
31   ${PN}-cli \
32 "
33
34 PACKAGE_ARCH_${PN}-cli = "all"
35 PACKAGE_ARCH_${PN}-data = "all"
36 PACKAGE_ARCH_${PN}-notes = "all"
37
38 SRC_URI = "git://git.shr-project.org/repo/opimd-utils.git;protocol=http"
39 S = "${WORKDIR}/git"
40 FILES_${PN} += "${sysconfdir}/X11/Xsession.d/89opimd-notifier"
41 FILES_${PN} += "${prefix}/share/applications/"
42 FILES_${PN} += "${prefix}/share/pixmaps/"
43 FILES_${PN}-data += "${prefix}/share/pixmaps/opimd-utils/"
44 FILES_${PN}-cli += "${prefix}/bin/opimd-cli"
45 FILES_${PN}-notes += "${prefix}/bin/opimd-notes"
46 FILES_${PN}-notes += "${prefix}/share/pixmaps/opimd-notes.png"
47 FILES_${PN}-notes += "${prefix}/share/applications/opimd-notes.desktop"