[crashreport] import plugin.
[vuplus_openembedded] / recipes / freesmartphone / fso-specs_git.bb
1 DESCRIPTIONS = "API Specification for freesmartphone.org"
2 AUTHOR = "Michael 'Mickey' Lauer"
3 HOMEPAGE = "http://docs.freesmartphone.org"
4 LICENSE = "BSD"
5 DEPENDS = "libxslt-native"
6 SECTION = "devel/specifications"
7 PV = "0.5.0-gitr${SRCREV}"
8 PR = "r0"
9
10 SRC_URI = "${FREESMARTPHONE_GIT}/specs.git;protocol=git;branch=master"
11 S = "${WORKDIR}/git"
12
13 do_compile() {
14         make xml
15 }
16
17 do_stage() {
18         install -d "${STAGING_DATADIR}/fso-specs"
19         install -m 0644 xml/* "${STAGING_DATADIR}/fso-specs"
20 }
21
22 FILE_${PN}-dev += "${datadir}/fso-specs"