Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into...
[vuplus_openembedded] / recipes / fpdf / fpdf_1.53.bb
1 DESCRIPTION = "Free PDF Creator for PHP"
2 SECTION = "libs"
3 DEPENDS = ""
4 RDEPENDS = "php"
5 LICENSE = "FREEWARE"
6 PR = "r0"
7
8 SRC_URI = "http://www.fpdf.org/en/download/fpdf153.tgz \
9            "
10
11 S = "${WORKDIR}/fpdf153"
12 do_compile() {
13     :
14 }
15
16 do_install() {
17     install -d  ${D}/usr \
18                 ${D}/usr/fpdf \
19                 ${D}/usr/fpdf/font \
20                 ${D}/usr/fpdf/font/makefont
21
22     install -m 644 ${S}/fpdf.php              ${D}/usr/fpdf/
23     install -m 644 ${S}/fpdf.css              ${D}/usr/fpdf/
24     install -m 644 ${S}/font/*.php            ${D}/usr/fpdf/font/
25     install -m 644 ${S}/font/makefont/*       ${D}/usr/fpdf/font/makefont/      
26 }
27
28 FILES_${PN} = "${exec_prefix}/fpdf/*.* \
29                ${exec_prefix}/fpdf/font/*.* \
30               "
31 FILES_${PN}-dev = "${exec_prefix}/fpdf/font/makefont/*"
32