Merge branch 'master' of git://dev.doredevelopment.dk/oe-micro into org.openembedded.dev
[vuplus_openembedded] / recipes / flickcurl / flickcurl_1.9.bb
1 DESCRIPTION = "flickcurl is a C libarry for the Flick API"
2 SECTION = "libs"
3 HOMEPAGE = "http://librdf.org/flickcurl/"
4 LICENSE = "LGPL 2.1/GPL 2/Apache 2.0"
5 PR = "r0"
6 SRC_URI = "http://download.dajobe.org/${PN}/${PN}-${PV}.tar.gz"
7
8 DEPENDS = "curl libxml2"
9
10 EXTRA_OECONF = "ac_cv_func_vsnprintf=no"
11
12 inherit autotools
13
14 do_stage() {
15          install -d ${STAGING_INCDIR}
16          install -m 0644 ${D}/usr/include/*.h ${STAGING_INCDIR}
17          oe_libinstall -so libflickcurl ${STAGING_LIBDIR}
18 }
19
20 LEAD_SONAME = "libflickcurl.so.1"
21
22 FILES_${PN} += "${libdir}/libflickcurl.so.*"