change usbtunerhelper src_uri.
[vuplus_openembedded] / recipes / ffmpeg / ffmpeg_0.4.9-pre1.bb
1 require ffmpeg.inc
2
3 PR = "r9"
4
5 SRC_URI = "${SOURCEFORGE_MIRROR}/ffmpeg/ffmpeg-${PV}.tar.gz \
6            file://configure.patch;patch=0 \
7            file://gcc4.patch;patch=1 \
8            file://soname.patch;patch=1 \
9            file://Makefile-avformat-use-LDFLAGS.patch;patch=1 \
10            file://Makefile-add-liblame.patch;patch=1 \
11            file://install-must-not-strip.patch;patch=1 \
12           "
13
14 EXTRA_OECONF += " \
15         \
16         --prefix=${D}${prefix} \
17         --mandir=${D}${prefix}/share/man \
18         \
19         --enable-mp3lame \
20         --enable-vorbis \
21         --enable-faad \
22         --enable-faadbin \
23         --enable-faac \
24         --enable-a52 \
25         --enable-a52bin \
26         --enable-shared-pp \
27         --disable-amr_nb \
28         --enable-amr_nb-fixed \
29         --disable-amr_wb \
30         \
31         --cpu=${TARGET_ARCH} \
32         --tune=${PACKAGE_ARCH} \
33         --extra-libs="-la52" \
34         --extra-ldflags="-L${STAGING_LIBDIR}" \
35         \
36         --disable-audio-beos \
37         --disable-v4l \
38         --disable-dv1394 \
39 "
40
41 EXTRA_OECONF_append_x86 += " \
42         --disable-mmx \
43 "
44
45 do_stage() {
46         oe_libinstall -a -so -C libavcodec  libavcodec ${STAGING_LIBDIR}
47         oe_libinstall -a -so -C libavformat libavformat ${STAGING_LIBDIR}
48
49         install -d ${STAGING_INCDIR}/ffmpeg
50
51         install -m 0644 ${S}/libavcodec/avcodec.h  ${STAGING_INCDIR}/ffmpeg/avcodec.h
52         install -m 0644 ${S}/libavcodec/common.h   ${STAGING_INCDIR}/ffmpeg/common.h
53         install -m 0644 ${S}/libavcodec/rational.h ${STAGING_INCDIR}/ffmpeg/rational.h
54
55         install -m 0644 ${S}/libavformat/avformat.h  ${STAGING_INCDIR}/ffmpeg/avformat.h
56         install -m 0644 ${S}/libavformat/avio.h      ${STAGING_INCDIR}/ffmpeg/avio.h
57         install -m 0644 ${S}/libavformat/rtp.h       ${STAGING_INCDIR}/ffmpeg/rtp.h
58         install -m 0644 ${S}/libavformat/rtsp.h      ${STAGING_INCDIR}/ffmpeg/rtsp.h
59         install -m 0644 ${S}/libavformat/rtspcodes.h ${STAGING_INCDIR}/ffmpeg/rtspcodes.h
60 }
61
62 PACKAGES += "libavcodec libavcodec-dev \ 
63              libavformat libavformat-dev"
64
65 FILES_libavcodec = "${libdir}/libavcodec*.so.*"
66 FILES_libavcodec-dev = "${libdir}/libavcodec*.so"
67 FILES_libavformat = "${libdir}/libavformat*.so.*"
68 FILES_libavformat-dev = "${libdir}/libavformat*.so"