dvbapp : TranscodingSetup update
[vuplus_openembedded] / recipes / fbv / fbv_1.0b.bb
1 DESCRIPTION = "Frame Buffer Viewer"
2 LICENSE = "GPL"
3 DEPENDS = "libpng"
4 PR = "r1"
5
6 SRC_URI = "http://s-tech.elsat.net.pl/fbv/fbv-1.0b.tar.gz \
7            file://cross_compile.patch;patch=1"
8
9 do_configure() {
10         CC="${CC}" ./configure --without-libungif --without-bmp \
11                 --without-libjpeg
12 }
13
14 do_compile() {
15         oe_runmake CFLAGS="-O2 -Wall -D_GNU_SOURCE -D__KERNEL_STRICT_NAMES" \
16                 CC="${CC}"
17 }
18 do_install() {
19         install -d ${D}${bindir}
20         install -m 0755 fbv ${D}${bindir}
21
22         # man
23         install -d ${D}${mandir}/man1/
24         install -m 0644 fbv.1 ${D}${mandir}/man1/fbv.1
25 }