Merge branch 'vuplus-1.6k' of code.vuplus.com:/opt/repository/openembedded into vuplu...
[vuplus_openembedded] / recipes / fbprogress / fbprogress_1.1.bb
1 DESCRIPTION = "Bug framebuffer progress indicator"
2 AUTHOR = "Angel Roman"
3 HOMEPAGE = "http://www.buglabs.net/"
4 LICENSE = "GPL"
5 DEPENDS = "freetype zlib virtual/kernel"
6 SRCREV = "9405"
7 PR = "r2"
8
9 SRC_URI = "svn://svn.buglabs.net/bug/trunk;module=com.buglabs.bug.native.fbprogress;proto=svn \
10            file://fbprogress-init"
11
12 S = "${WORKDIR}/com.buglabs.bug.native.fbprogress"
13
14 inherit update-rc.d
15
16 TARGET_CXXFLAGS += "-I${STAGING_INCDIR}/freetype2 -I${STAGING_KERNEL_DIR}/include"
17 TARGET_LDFLAGS  += "-L${STAGING_LIBDIR} -lfreetype -lz"
18
19 do_install() {
20   install -d ${D}/${datadir}/fbprogress
21   install -m 0644 ${S}/images/* ${D}/${datadir}/fbprogress/
22
23   install -d ${D}${bindir}
24   install -m 0755 fbprogress ${D}${bindir}
25   install -m 0755 fbprogress.sh ${D}${bindir}
26
27   install -d ${D}/${sysconfdir}/init.d
28   install -m 0755 ${WORKDIR}/fbprogress-init ${D}/${sysconfdir}/init.d/fbprogress
29 }
30
31 PACKAGE_ARCH = "${MACHINE_ARCH}"
32 COMPATIBLE_MACHINE = "bug"
33
34 INITSCRIPT_NAME = "fbprogress"
35 INITSCRIPT_PARAMS = "start 01 S . stop 15  0 1 2 3 4 5 6 ."