Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into...
[vuplus_openembedded] / recipes / fastjar / fastjar-native_0.95.bb
1 DESCRIPTION = "jar replacement written in C."
2 HOMEPAGE = "http://savannah.nongnu.org/projects/fastjar/"
3 SECTION = "devel"
4 PRIORITY = "optional"
5 LICENSE = "GPL"
6
7 PR = "r1"
8
9 DEPENDS = "zlib-native"
10
11 SRC_URI = "http://download.savannah.nongnu.org/releases/fastjar/fastjar-${PV}.tar.gz"
12
13 S = "${WORKDIR}/fastjar-${PV}"
14
15 inherit autotools native
16
17 EXTRA_OECONF = "--with-system-zlib --with-fastjar"
18
19 do_configure () {
20         gnu-configize || die "failure running gnu-configize"
21         oe_runconf
22 }
23
24 do_stage() {
25         #we should teach autotools.bbclass:autotools_stage_all() about ${STAGING_BINDIR}
26         install -d ${STAGING_BINDIR}
27         install -m 755 .libs/fastjar ${STAGING_BINDIR}/fastjar
28         install -m 755 .libs/grepjar ${STAGING_BINDIR}
29 }